[Ambulant-users] Timing bug in Ambulant?

Chris Abrams cja5 at onetel.com
Mon Aug 25 23:57:43 CEST 2008


On Mon, 2008-08-25 at 13:19 +0200, Jack Jansen wrote:
On 23 aug 2008, at 14:51, Chris Abrams wrote:
> > I'm a relative newcomer to SMIL but I'm confused as to the behaviour
> > of the
> > Ambulant Player when given the following SMIL:
> >
> > <?xml version="1.0" encoding="UTF-8"?>
> >
> > <!DOCTYPE smil PUBLIC "-//W3C//DTD SMIL 2.0//EN"
> >                      "http://www.w3.org/2001/SMIL20/SMIL20.dtd">
> >
> > <smil xmlns="http://www.w3.org/2001/SMIL20/Language">
> >    <head>
> >        <layout type="text/smil-basic-layout">
> >            <root-layout width="400" height="300"
> > backgroundColor="#FFFFFF" />
> >            <region regionName="img" left="25" width="350" top="25"
> > height="250"
> > backgroundColor="transparent" showBackground="whenActive" />
> >        </layout>
> >    </head>
> >    <body>
> >        <seq repeatCount="indefinite">
> >            <img src="a.gif" dur="1.5s" region="img" fill="remove" />
> >            <img src="b.gif" dur="1.5s" region="img" fill="remove" />
> >            <img src="c.gif" dur="1.5s" region="img" fill="remove" />
> >        </seq>
> >    </body>
> > </smil>
> >
> > I would have expected the sequence of images a, b and c to be repeated
> > indefinitetly. However, when run on either Ambulant 1.8 on Windows
> > or the
> > latest Ambulant Player built from source and running under Linux,
> > the sequence
> > of images is shown just once before play stops.
>
> It was indeed a bug, and it has been fixed in the CVS source tree.
>
> Thanks for the report,
> --

Hi Jack

No problem and many thanks for the rapid fix! Its working great for me now.

Kind regards

Chris Abrams.



More information about the Ambulant-users mailing list