[Ambulant-users] Ambulant not playing RTSP feeds.

Jack Jansen Jack.Jansen at cwi.nl
Mon Jan 23 22:28:11 CET 2012


James,
There are a number of issues with rtsp. Some are our fault, others are problems with the way rtsp servers are setup and general problems with rtsp. And it could indeed be the case that there is a build problem too.

First thing to check is that your build includes live555. Check the configure log, and if live555 wasn't included fix that and try again. Live555 is required for ambulant to be able to play rtsp.

Next thing to check is that there isn't a problem with the encoding of your file (triggered by the no suitable codec message you report): try and copy the media from the rtsp server to a local file and check that ambulant can play it back then.

If local playback does work you may be running into a shortcoming of ambulant: it doesn't do automatic switching between UDP and TCP as transport mechanisms. So if you there is a firewall between the client machine and the rtsp server you have to manually enable tcp transport in the ambulant settings. Fixing this is on our to do list, but it is not very high priority.

If that still doesn't work: please set log level in ambulant to "debug", and send us both the log output and your smil document.

Sent from my iPad

On Jan 23, 2012, at 15:01, "James Moyle" <mail at 3piece.asia> wrote:

> Good day ambulant-users at ambulantplayer.org,
> 
> Hello all, I have compiled Ambulant from the nightly builds (as the stable build did not work) on my platform which is Fedora core 16 x64.
> 
> When ever I try to load a rtsp feed via an smil file, it fails to load in ambulant giving the following error: "rtsp://..... Cannot open, not supported by any video datasource"
> 
> I've tried my own local RTSP feeds as well as using the SMIL file from Video Test SMIL file from the testing page.
> 
> If I use ffplay to load the url in the SMIL file, it plays fine.
> 
> Mplayer (Totem) plays the SMIL file and video fine, however instead of following the SMIL formatting conventions, it just builds a play list with all the media objects defined.
> 
> As a sanity check, I checked on a windows 7 machine, I found a similar problem to begin with, however it was partially resolved when I added ffmpeg bin directory to the windows path. Now after selecting "use ffmpeg instead of direct draw" the test SMIL video shows the rtsp feed of the man turning the torch on, however when trying to play our local rtsp feeds, it still fails to render the feeds with the following errors:
> 
> "rtsp://my.local.domain:port/udpstream_ch1_stream1: Ignoring audio, No suitable codec" or something similar, however I think this only pertains to the audio.
> 
> Is there something wrong with the way I have compiled the Ambulant the program? Has anybody experienced this before?
> 
> Best Regards, 3piece
> 
> ----- Reply message -----
> From: ambulant-users-owner at ambulantplayer.org
> To: <mail at 3piece.asia>
> Subject: Ambulant not playing RTSP feeds.
> Date: Mon, Jan 23, 2012 18:59
> 
> 
> To reduce the amount of spam received, posting to the ambulant-users
> mailing list is only allowed for list members.
> 
> Please subscribe to this list and then re-post your message.
> 
> Alternatively, if you really don't want to subscribe, you can post to
> the ambulant-feedback address, and to the top of your message add a
> line [PLEASE POST TO AMBULANT-USERS] and we will post it for you.
> 
> _______________________________________________
> Ambulant-users mailing list
> Ambulant-users at ambulantplayer.org
> http://www.ambulantplayer.org/mailman/listinfo/ambulant-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ambulantplayer.org/pipermail/ambulant-users/attachments/20120123/cb8413e2/attachment.html>


More information about the Ambulant-users mailing list