[Ambulant-users] Ambulant not playing RTSP feeds.

James Moyle mail at 3piece.asia
Tue Jan 24 11:19:01 CET 2012


Hi Jack,

	Thanks for the response, well I finally got live555 installed
	(had to use the "./genMakefiles linux-64bit" command as I'm
	running 64 bit.) making sure it was in the live folder under
	the third_party_packages folder.

	I then ran the commands:
	">sudo ./configure --with-live
	>sudo make
	>sudo make install"

	from the root folder. (Do I need to remake after a re-config?)

	I then used the following ffmpeg command to record down the
	rtsp feeds down:
	"ffmpeg -i rtsp://192.168.2.60:554/udpstream_ch1_stream1 -an
	-vcodec copy -t 20 test_rtsp_L_001.mkv"

	etc.

	Then modified the SMIL file from the following lines
	"<video
	src="rtsp://192.168.2.60:554/udpstream_ch1_stream1"
	dur="indefinite" region="video_left"/> 
	<video src="rtsp://192.168.2.61/udpstream_ch1_stream1"
	dur="indefinite" region="video_center"/>
	<video src="rtsp://192.168.2.62:554/udpstream_ch1_stream1"
	dur="indefinite" region="video_right"/>"

	To

	"<video src="test_rtsp_L_001.mkv" region="video_left"/>
	<video src="test_rtsp_C_001.mkv" region="video_center"/>
	<video src="test_rtsp_R_001.mkv" region="video_right"/>"

	The local versions of the files played, however I received the
	same error when trying to run the remote RTSP feeds.

	There is no option to change UDP to TCP via the preferences
	dialogue box in linux, however following the instructions from
	the manual, I have disabled iptables(the firewall) on Fedora
	16. I have also only got one switch connected between the rtsp
	servers and my test machines. It's a local network.

	Here is the copy of the Log window with log level set to Debug:

	---Debug Log----
	
	18:13:14.672082 DEBUG Ambulant Player: now logging to a window
	
	18:13:14.672324 DEBUG Ambulant Player: compile time version 2.3,
	runtime version 2.3 18:13:14.672454 DEBUG Ambulant Player:
	built on Jan 21 2012 for Unix/GTK 18:13:14.672662 DEBUG
	Ambulant Player: localization enabled (english)

	18:13:14.674582 TRACE plugin_engine: using LTDL plugin loader

	18:13:14.674652 TRACE plugin_engine: Scanning plugin
	directory: /usr/local/lib/ambulant 18:13:14.674760 TRACE
	plugin_engine:
	loading /usr/local/lib/ambulant/libamplugin_xpath_state.la

	18:13:14.674995 TRACE plugin_engine: Done with plugin
	directory: /usr/local/lib/ambulant 18:13:14.675033 TRACE
	xpath_state_plugin: registered 18:13:14.675093 TRACE
	file:///home/3piece/Documents/Current_Work/Xaphe/Dev/SMIL/ambulant-2.3/testbed/test_vid.smil:
	Parsing document... 
	
	18:13:14.675132 TRACE Using parser xerces

	18:13:14.675158 WARN Parser "xerces" not available, using
	"expat" 

	18:13:14.697644 TRACE
	file:///home/3piece/Documents/Current_Work/Xaphe/Dev/SMIL/ambulant-2.3/testbed/test_vid.smil:
	Parser done

	18:13:14.697713 DEBUG  creating smil2 player
	parser: xerces, validation_scheme: always, do_namespaces: yes,
	do_schema: no, validation_schema_full_checking: yes,
	strict_url_parsing: no, m_tabbed_links: no, prefer_ffmpeg: yes,
	use_plugins: yes, plugin_dir: , dynamic_content_control: no,
	fullscreen: no, prefer_rtsp_tcp: no

	18:13:14.698453 WARN
	rtsp://192.168.2.60:554/udpstream_ch1_stream1: Cannot open, not
	supported by any video datasource

	18:13:14.703065 WARN Cannot
	open video: rtsp://192.168.2.60:554/udpstream_ch1_stream1
	

	18:13:14.706112 TRACE video_renderer.preroll: no datasource,
	skipping media item 18:13:14.706146 TRACE video_renderer.start:
	no datasource, skipping media item 

	18:13:14.706243 WARN
	rtsp://192.168.2.61/udpstream_ch1_stream1: Cannot open, not
	supported by any video datasource 

	18:13:14.713297 WARN Cannot
	open video: rtsp://192.168.2.61/udpstream_ch1_stream1
	
	18:13:14.720954 TRACE video_renderer.preroll: no datasource,
	skipping media item 

	18:13:14.720986 TRACE video_renderer.start:
	no datasource, skipping media item 

	18:13:14.721073 WARN
	rtsp://192.168.2.62:554/udpstream_ch1_stream1: Cannot open, not
	supported by any video datasource 

	18:13:14.732374 WARN Cannot
	open video: rtsp://192.168.2.62:554/udpstream_ch1_stream1
	
	18:13:14.735573 TRACE video_renderer.preroll: no datasource,
	skipping media item 

	18:13:14.735612 TRACE video_renderer.start: no datasource,
	skipping media item

	---Debug Log----

	It seems to be the issue with trying to get the RTSP
	feed coming through.

	I can play the same SMIL file in Totem and it works as
	described in my previous post.

	Any other suggestions?
	

Best Regards,
3piece

--

On Mon, 23 Jan 2012 22:28:11 +0100
Jack Jansen <Jack.Jansen at cwi.nl> wrote:

> James,
> There are a number of issues with rtsp. Some are our fault, others
> are problems with the way rtsp servers are setup and general problems
> with rtsp. And it could indeed be the case that there is a build
> problem too.
> 
> First thing to check is that your build includes live555. Check the
> configure log, and if live555 wasn't included fix that and try again.
> Live555 is required for ambulant to be able to play rtsp.
> 
> Next thing to check is that there isn't a problem with the encoding
> of your file (triggered by the no suitable codec message you report):
> try and copy the media from the rtsp server to a local file and check
> that ambulant can play it back then.
> 
> If local playback does work you may be running into a shortcoming of
> ambulant: it doesn't do automatic switching between UDP and TCP as
> transport mechanisms. So if you there is a firewall between the
> client machine and the rtsp server you have to manually enable tcp
> transport in the ambulant settings. Fixing this is on our to do list,
> but it is not very high priority.
> 
> If that still doesn't work: please set log level in ambulant to
> "debug", and send us both the log output and your smil document.
> 
> Sent from my iPad
> 
> On Jan 23, 2012, at 15:01, "James Moyle" <mail at 3piece.asia> wrote:
> 
> > Good day ambulant-users at ambulantplayer.org,
> > 
> > Hello all, I have compiled Ambulant from the nightly builds (as the
> > stable build did not work) on my platform which is Fedora core 16
> > x64.
> > 
> > When ever I try to load a rtsp feed via an smil file, it fails to
> > load in ambulant giving the following error: "rtsp://..... Cannot
> > open, not supported by any video datasource"
> > 
> > I've tried my own local RTSP feeds as well as using the SMIL file
> > from Video Test SMIL file from the testing page.
> > 
> > If I use ffplay to load the url in the SMIL file, it plays fine.
> > 
> > Mplayer (Totem) plays the SMIL file and video fine, however instead
> > of following the SMIL formatting conventions, it just builds a play
> > list with all the media objects defined.
> > 
> > As a sanity check, I checked on a windows 7 machine, I found a
> > similar problem to begin with, however it was partially resolved
> > when I added ffmpeg bin directory to the windows path. Now after
> > selecting "use ffmpeg instead of direct draw" the test SMIL video
> > shows the rtsp feed of the man turning the torch on, however when
> > trying to play our local rtsp feeds, it still fails to render the
> > feeds with the following errors:
> > 
> > "rtsp://my.local.domain:port/udpstream_ch1_stream1: Ignoring audio,
> > No suitable codec" or something similar, however I think this only
> > pertains to the audio.
> > 
> > Is there something wrong with the way I have compiled the Ambulant
> > the program? Has anybody experienced this before?
> > 
> > Best Regards, 3piece
> > 
> > ----- Reply message -----
> > From: ambulant-users-owner at ambulantplayer.org
> > To: <mail at 3piece.asia>
> > Subject: Ambulant not playing RTSP feeds.
> > Date: Mon, Jan 23, 2012 18:59
> > 
> > 
> > To reduce the amount of spam received, posting to the ambulant-users
> > mailing list is only allowed for list members.
> > 
> > Please subscribe to this list and then re-post your message.
> > 
> > Alternatively, if you really don't want to subscribe, you can post
> > to the ambulant-feedback address, and to the top of your message
> > add a line [PLEASE POST TO AMBULANT-USERS] and we will post it for
> > you.
> > 
> > _______________________________________________
> > Ambulant-users mailing list
> > Ambulant-users at ambulantplayer.org
> > http://www.ambulantplayer.org/mailman/listinfo/ambulant-users






More information about the Ambulant-users mailing list